Added comments about source of description, etc.
[mmh] / nmh.spec
1 # Assumes that rpmbuild was invoked in main nmh directory using "make
2 # rpm".  Therefore, configure must already have been run.  "make rpm"
3 # uses an RPM directory below the current directory.
4 #
5 # This file is intended to be zero maintenance, that's why it relies
6 # on the Makefile (and specifically on the nmhdist target).  If you
7 # really want to start with rpmbuild from a clean distribution, you'll
8 # need to first run configure, make, and make nmhdist.
9 #
10 # Note that Version cannot contain any dashes.
11 #
12 # The description, summary, and a few other tags were taken from the
13 # nmh.spec used to build the Fedora 15 nmh rpm.
14
15 Name:        nmh
16 Version:     %version
17 Release:     0%{?dist}
18 Summary:     A capable mail handling system with a command line interface.
19 Group:       Applications/Internet
20 License:     BSD
21 URL:         http://savannah.nongnu.org/projects/nmh
22 Source:      %tarfile
23 # This should already be defined in /usr/lib/rpm/macros:
24 # BuildRoot:   %{_buildrootdir}/%{name}-%{version}-%{release}.%{_arch}
25
26 %description
27 Nmh is an email system based on the MH email system and is intended to
28 be a (mostly) compatible drop-in replacement for MH.  Nmh isn't a
29 single comprehensive program.  Instead, it consists of a number of
30 fairly simple single-purpose programs for sending, receiving, saving,
31 retrieving and otherwise manipulating email messages.  You can freely
32 intersperse nmh commands with other shell commands or write custom
33 scripts which utilize nmh commands.  If you want to use nmh as a true
34 email user agent, you'll want to also install exmh to provide a user
35 interface for it--nmh only has a command line interface.
36
37
38 %prep
39 #### The tarfile is only needed for the source rpm.
40 cp -p %srcdir/%tarfile $RPM_SOURCE_DIR
41
42
43 %build
44
45
46 %install
47 rm -rf $RPM_BUILD_ROOT doc
48 (cd %srcdir  &&  make install DESTDIR=$RPM_BUILD_ROOT SETGID_MAIL=)
49 #### Exclude docs from nmh_files because its files are added with the
50 #### %doc directive in the %files section below.
51 mv `find $RPM_BUILD_ROOT -type d -name doc` .
52 find $RPM_BUILD_ROOT ! -type d -print | sed "s#^$RPM_BUILD_ROOT##" > nmh_files
53
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT $RPM_SOURCE_DIR/%tarfile nmh_files doc
57
58
59 %files -f nmh_files
60 %defattr(-,root,root,-)
61 %doc doc/*