Merge branch 'master' of git.sv.nongnu.org:/srv/git/nmh
[mmh] / nmh.spec
1 # Assumes that rpmbuild was invoked in main nmh directory using "make
2 # rpm".  Therefore, configure must already have been run.  "make rpm"
3 # uses an RPM directory below the current directory.
4 #
5 # This file is intended to be zero maintenance, that's why it relies
6 # on the Makefile (and specifically on the nmhdist target).  If you
7 # really want to start with rpmbuild from a clean distribution, look
8 # at the rpm target in the main Makefile.in to see what it does.
9 #
10 # Note that Version cannot contain any dashes.
11
12 Name:        nmh
13 Version:     %version
14 Release:     0%{?dist}
15 Summary:     A capable mail handling system with a command line interface.
16 Group:       Applications/Internet
17 License:     BSD
18 URL:         http://savannah.nongnu.org/projects/nmh
19 Source:      %tarfile
20 # This should already be defined in /usr/lib/rpm/macros:
21 # BuildRoot:   %{_buildrootdir}/%{name}-%{version}-%{release}.%{_arch}
22
23 %description
24 Nmh is an email system based on the MH email system and is intended to
25 be a (mostly) compatible drop-in replacement for MH.  Nmh isn't a
26 single comprehensive program.  Instead, it consists of a number of
27 fairly simple single-purpose programs for sending, receiving, saving,
28 retrieving and otherwise manipulating email messages.  You can freely
29 intersperse nmh commands with other shell commands or write custom
30 scripts which utilize nmh commands.  If you want to use nmh as a true
31 email user agent, you'll want to also install exmh to provide a user
32 interface for it--nmh only has a command line interface.
33
34 %prep
35 #### The tarfile is only needed for the source rpm.
36 cp -p %srcdir/%tarfile $RPM_SOURCE_DIR
37
38
39 %build
40
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44 (cd %srcdir  &&  make install DESTDIR=$RPM_BUILD_ROOT SETGID_MAIL=)
45 find $RPM_BUILD_ROOT ! -type d -print | sed "s#^$RPM_BUILD_ROOT##g" > nmh_files
46
47 #### Should do the following with an install target in docs/Makefile.
48 #### These are excluded from nmh_files above because they're added
49 #### with doc's in the %files section below.
50 mkdir -p docs
51 cp -p %srcdir/VERSION %srcdir/COPYRIGHT .
52 for i in COMPLETION-* DIFFERENCES FAQ MAIL.FILTERING README* TODO; do
53   cp -p %srcdir/docs/$i docs
54 done
55
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT $RPM_SOURCE_DIR/%tarfile nmh_files docs COPYRIGHT VERSION
59
60
61 %files -f nmh_files
62 %defattr(-,root,root,-)
63 %doc docs/COMPLETION-* docs/DIFFERENCES docs/FAQ docs/MAIL.FILTERING
64 %doc docs/README* docs/TODO COPYRIGHT VERSION