The docs/Makefile install target didn't do anything before. Added
[mmh] / nmh.spec
1 # Assumes that rpmbuild was invoked in main nmh directory using "make
2 # rpm".  Therefore, configure must already have been run.  "make rpm"
3 # uses an RPM directory below the current directory.
4 #
5 # This file is intended to be zero maintenance, that's why it relies
6 # on the Makefile (and specifically on the nmhdist target).  If you
7 # really want to start with rpmbuild from a clean distribution, look
8 # at the rpm target in the main Makefile.in to see what it does.
9 #
10 # Note that Version cannot contain any dashes.
11
12 Name:        nmh
13 Version:     %version
14 Release:     0%{?dist}
15 Summary:     A capable mail handling system with a command line interface.
16 Group:       Applications/Internet
17 License:     BSD
18 URL:         http://savannah.nongnu.org/projects/nmh
19 Source:      %tarfile
20 # This should already be defined in /usr/lib/rpm/macros:
21 # BuildRoot:   %{_buildrootdir}/%{name}-%{version}-%{release}.%{_arch}
22
23 %description
24 Nmh is an email system based on the MH email system and is intended to
25 be a (mostly) compatible drop-in replacement for MH.  Nmh isn't a
26 single comprehensive program.  Instead, it consists of a number of
27 fairly simple single-purpose programs for sending, receiving, saving,
28 retrieving and otherwise manipulating email messages.  You can freely
29 intersperse nmh commands with other shell commands or write custom
30 scripts which utilize nmh commands.  If you want to use nmh as a true
31 email user agent, you'll want to also install exmh to provide a user
32 interface for it--nmh only has a command line interface.
33
34 %prep
35 #### The tarfile is only needed for the source rpm.
36 cp -p %srcdir/%tarfile $RPM_SOURCE_DIR
37
38
39 %build
40
41
42 %install
43 rm -rf $RPM_BUILD_ROOT doc
44 (cd %srcdir  &&  make install DESTDIR=$RPM_BUILD_ROOT SETGID_MAIL=)
45 #### Exclude docs from nmh_files because its files are added with the
46 #### %doc directive in the %files section below.
47 mv `find $RPM_BUILD_ROOT -type d -name doc` .
48 find $RPM_BUILD_ROOT ! -type d -print | sed "s#^$RPM_BUILD_ROOT##" > nmh_files
49
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT $RPM_SOURCE_DIR/%tarfile nmh_files doc
53
54
55 %files -f nmh_files
56 %defattr(-,root,root,-)
57 %doc doc/*